WordPress – SyntaxHighlighter Evolvedプラグイン


SyntaxHighlighter Evolvedプラグインは、文章中のソースコードを整形するためのプラグインです。

インストール方法は以下の通りです。

1.SyntaxHighlighter Evolvedからダウンロードします。

2.ダウンロードしたファイルを解凍し、“syntaxhighlighter”フォルダを、wp-content/pluginsにアップロードします。

3.プラグインの管理画面で、“SyntaxHighlighter Evolved”の「使用する」リンクを押下し、プラグインを有効化します。

使い方は、文章中のソースコードを[ソースの種類]タグで囲むだけです。

ソースコードと[ソースの種類]タグの対応は以下の通りです。

ソースコード [ソースの種類]タグ
ActionScript3 as3
actionscript3
Bash/shell bash
shell
C# c-sharp
csharp
C++ cpp
c
CSS css
Delphi delphi
pas
pascal
Diff diff
patch
Groovy groovy
JavaScript js
jscript
javascript
Java java
JavaFX jfx
javafx
Perl perl
pl
PHP php
Plain Text plain
text
PowerShell ps
powershell
Python py
python
Ruby rails
ror
ruby
Scala scala
SQL sql
Visual Basic vb
vbnet
XML xml
xhtml
xslt
html
xhtml

関連記事

  1. コメント 0

  1. トラックバック 0

return top